2016年5月18日水曜日

UbuntuでPHPをコマンドラインから使用して、SNMP関連のエラーが出る場合

UbuntuでPHPをコマンドラインから使用して、SNMP関連のエラーが出る場合の対処法です。今回エラーが出た環境は、Ubuntu 14.04、PHP 5.5.9。結構、豪快にエラーが出て、何が起こったのかと思いました。SNMPを利用していなければ、php5-snmpをアンインストールすれば大丈夫なようです。

Cannot find module (SNMPv2-TC): 
...
...
...
Cannot adopt OID in UCD-SNMP-MIB:
php5-snmpをアンインストール
sudo apt-get remove php5-snmp
これでエラーが出なくなって、平穏無事な環境を取り戻しました。

参考サイト
Ubuntu typing 'php' in terminal shows a lot of errors(Stack Overflow)

0 件のコメント:

コメントを投稿