2016年3月23日水曜日

Apache(2.4.18)をソースからインストール

Apache(2.4.18)をソースからインストールです。APR、APR-Util、PCREがそれぞれ必要らしいです。環境は、CentOS6.5です。

apr-1.5.2
tar zxvf apr-1.5.2.tar.gz
cd apr-1.5.2
./configure --prefix=/opt/apr-1.5.2
make
make install
apr-util-1.5.4
tar zxvf apr-util-1.5.4.tar.gz
cd apr-util-1.5.4
./configure --prefix=/opt/apr-util-1.5.4 --with-apr=/opt/apr-1.5.2
make
make install
pcre-8.38
tar zxvf pcre-8.38.tar.gz
cd pcre-8.38
./configure --prefix=/opt/pcre-8.38
make
make install
httpd-2.4.18
tar httpd-2.4.18.tar.gz
cd httpd-2.4.18
./configure --enable-ssl --with-apr=/opt/apr-1.5.2 --with-apr-util=/opt/apr-util-1.5.4 --with-pcre=/opt/pcre-8.38 --with-ssl
make
make install

参考サイト
Apache2.4系をソースからインストール(Qiita)
Apache httpd 2.4 をソースからインストールする手順 (CentOS/RedHat)(WEB ARCH LABOさん)

0 件のコメント:

コメントを投稿