2015年6月2日火曜日

PHPバリデーションクラス「GUMP」の日本語化

PHPバリデーションクラス「GUMP」の日本語化です。エラーメッセージを出力しているのは、get_readable_errorsget_errors_arrayのメソッドなので、これをオーバーライドしてしまうのが手っ取り早いと思います。

class GumpValidator extends GUMP
{
  public function get_readable_errors()
  {

  }

  public function get_errors_array()
  {

  }
} 

あとは、同じように
$gump = new GumpValidator();

実際に設定してみたサイトがこちら


参考サイト
Displaying Form Error Messages from Array(Stack Overflow)

0 件のコメント:

コメントを投稿